os中的指定python版本安装pip

  • 检查当前python版本和pip版本(终端输入)
    • which python
    • which python3
    • which python3.x
    • which pip
    • which pip3
    • which pip3.x

赘述

由于懵懂期间为了图省事,把mac自带的Python2.7覆盖了,以至于现在python不是原来的python2.7,而是anaconda覆盖掉的3.8.8版本,以至于系统好多冗余的东西!但是由于个人比较懒(其实更是因为自己还是稚嫩),毕竟系统里面很多东西都不想重装了。

重点

经过检查后,今日目标是为python3.9安装pip。终端运行下面的代码:

curl https://bootstrap.pypa.io/get-pip.py | python3.9

经过「短暂」的下载、安装等待时间后,显示
Successfully installed....
即表示安装成功。然后检查一下,并看一下已经安装了什么库(终端输入):

which pip3.9
pip3.9 list

随后,根据需求安装库就好。

pip3.9 install pandas
pip3.9 install numpy